do_sqlite3 conflict

Nov 21, 2008

Today I upgraded my gems and all of a sudden all my sqlite3 db’s failed.

All the tasks using rake db:**** rake aborted! no such file to load -- sqlite3 This all includes all script/server and passenger uses of the sqlite db.

The gem datamapper do_sqlite3 somehow interfers with the sqlite3-ruby gem. Simple answer gem uninstall do_sqlite3 -v=0.9.7. I uninstalled versions 0.9.7, as there is not a problem with the previous version 0.9.6.


This has been fixed as of 0.9.9 – Thank you

Posted by Thomas Cowell

Tags: rails